summaryrefslogtreecommitdiffstats
path: root/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch')
-rw-r--r--debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch12
1 files changed, 7 insertions, 5 deletions
diff --git a/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch b/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
index 5463e7b..0e12b31 100644
--- a/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
+++ b/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
@@ -9,17 +9,19 @@ fashion to what -Werror does to GCC or other compilers.
Therefore, I'm disabling this.
---
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
--- a/Makefile
+++ b/Makefile
-@@ -76,7 +76,7 @@ test:
- $(PYTHON) -m pytest
+@@ -77,8 +77,8 @@ test:
+ $(PYTHON) -m pytest -Werror
$(MAKE) codetest
-offlinetest: codetest
+- $(PYTHON) -m pytest -Werror -m "not download"
+offlinetest:
- $(PYTHON) -m pytest -k "not download"
++ $(PYTHON) -m pytest -m "not download"
CODE_FOLDERS_CMD = find yt_dlp -type f -name '__init__.py' | sed 's,/__init__.py,,' | grep -v '/__' | sort
+ CODE_FOLDERS != $(CODE_FOLDERS_CMD)