summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..3e4fe88
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+%:
+ dh ${@}
+
+override_dh_auto_configure:
+ dh_auto_configure -- --htmldir=/usr/share/doc/libdvdcss-dev/html
+
+execute_after_dh_auto_install:
+ # removing unused files
+ rm -f debian/tmp/usr/lib/*/libdvdcss.la
+ rm -rf debian/tmp/usr/share/doc/libdvdcss
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS