summaryrefslogtreecommitdiffstats
path: root/python/mozboot/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 15:11:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 15:11:26 +0000
commitfcea19dfd2c426bac0456da850e7c12258e4b9eb (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /python/mozboot/setup.py
parentAdding upstream version 115.7.0esr. (diff)
downloadfirefox-esr-upstream/115.8.0esr.tar.xz
firefox-esr-upstream/115.8.0esr.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/mozboot/setup.py')
-rw-r--r--python/mozboot/setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/mozboot/setup.py b/python/mozboot/setup.py
index 234650dc8a..7b12c1c0c5 100644
--- a/python/mozboot/setup.py
+++ b/python/mozboot/setup.py
@@ -2,7 +2,10 @@
# License, v. 2.0. If a copy of the MPL was not distributed with this file,
# You can obtain one at http://mozilla.org/MPL/2.0/.
-from distutils.core import setup
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
VERSION = "0.1"