summaryrefslogtreecommitdiffstats
path: root/security/nss/pkg/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /security/nss/pkg/Makefile
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'security/nss/pkg/Makefile')
-rw-r--r--security/nss/pkg/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/nss/pkg/Makefile b/security/nss/pkg/Makefile
new file mode 100644
index 0000000000..13c0910d36
--- /dev/null
+++ b/security/nss/pkg/Makefile
@@ -0,0 +1,27 @@
+#! gmake
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+CORE_DEPTH = ../..
+DEPTH = ../..
+
+include $(CORE_DEPTH)/coreconf/config.mk
+
+publish:
+ifeq ($(OS_TARGET),Linux)
+ rm -rf $(OBJDIR)
+ cp -r linux $(OBJDIR)
+ $(MAKE) -C $(OBJDIR) publish
+endif
+ifeq ($(OS_TARGET),SunOS)
+ rm -rf $(OBJDIR)
+ cp -r solaris $(OBJDIR)
+ $(MAKE) -C $(OBJDIR) publish
+endif
+
+clean::
+ rm -rf $(OBJDIR)
+
+include $(CORE_DEPTH)/coreconf/rules.mk