summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/compat/webkit-linear-gradient-diff-unprefixed.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/compat/webkit-linear-gradient-diff-unprefixed.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/compat/webkit-linear-gradient-diff-unprefixed.html')
-rw-r--r--testing/web-platform/tests/compat/webkit-linear-gradient-diff-unprefixed.html18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/web-platform/tests/compat/webkit-linear-gradient-diff-unprefixed.html b/testing/web-platform/tests/compat/webkit-linear-gradient-diff-unprefixed.html
new file mode 100644
index 0000000000..ee49dc4e15
--- /dev/null
+++ b/testing/web-platform/tests/compat/webkit-linear-gradient-diff-unprefixed.html
@@ -0,0 +1,18 @@
+<!DOCTYPE html>
+<title>Compatibility Test: -webkit-linear-gradient() diff with linear-gradient()</title>
+<link rel="help" href="https://compat.spec.whatwg.org/#css-gradients-webkit-linear-gradient">
+<link rel="match" href="webkit-linear-gradient-diff-unprefixed-ref.html">
+<style>
+ #square {
+ height: 100px;
+ width: 100px;
+ }
+</style>
+<p>You should see a square, orange at the top, blue at the bottom.</p>
+<div id="square"></div>
+<script>
+ square.offsetTop;
+ square.style.backgroundImage = "-webkit-linear-gradient(bottom, orange, blue)";
+ square.offsetTop;
+ square.style.backgroundImage = "linear-gradient(to bottom, orange, blue)";
+</script>