summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/compat/webkit-mask-box-enumeration.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/compat/webkit-mask-box-enumeration.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/compat/webkit-mask-box-enumeration.html')
-rw-r--r--testing/web-platform/tests/compat/webkit-mask-box-enumeration.html25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/web-platform/tests/compat/webkit-mask-box-enumeration.html b/testing/web-platform/tests/compat/webkit-mask-box-enumeration.html
new file mode 100644
index 0000000000..048170262a
--- /dev/null
+++ b/testing/web-platform/tests/compat/webkit-mask-box-enumeration.html
@@ -0,0 +1,25 @@
+<!DOCTYPE html>
+<title>WebKitMaxBoxImage on CSSStyleDeclaration</title>
+<link rel="help" href="https://compat.spec.whatwg.org/#css-simple-aliases">
+<meta name="assert" content="This test verifies that these WebKit properties are enumerated on CSSStyleDeclaration" />
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<body>
+</body>
+<script>
+const PREFIXED_PROPS = [
+ 'webkitMaskBoxImage',
+ 'webkitMaskBoxImageOutset',
+ 'webkitMaskBoxImageRepeat',
+ 'webkitMaskBoxImageSlice',
+ 'webkitMaskBoxImageSource',
+ 'webkitMaskBoxImageWidth',
+];
+
+const docBodyStyle = document.body.style;
+for (let prop of PREFIXED_PROPS) {
+ test(() => {
+ assert_true(prop in docBodyStyle);
+ }, `${prop} found on CSSStyleDeclaration`);
+}
+</script> \ No newline at end of file