summaryrefslogtreecommitdiffstats
path: root/third_party/rust/app_units/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/app_units/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/app_units/Cargo.toml')
-rw-r--r--third_party/rust/app_units/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/rust/app_units/Cargo.toml b/third_party/rust/app_units/Cargo.toml
new file mode 100644
index 0000000000..bf4d838c9a
--- /dev/null
+++ b/third_party/rust/app_units/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "app_units"
+version = "0.7.2"
+authors = ["The Servo Project Developers"]
+description = "Servo app units type (Au)"
+documentation = "https://docs.rs/app_units/"
+readme = "README.md"
+license = "MPL-2.0"
+repository = "https://github.com/servo/app_units"
+
+[dependencies.num-traits]
+version = "0.2"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+
+[features]
+default = [
+ "num_traits",
+ "serde_serialization",
+]
+num_traits = ["num-traits"]
+serde_serialization = ["serde"]