summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cubeb-core/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/cubeb-core/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cubeb-core/Cargo.toml')
-rw-r--r--third_party/rust/cubeb-core/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/third_party/rust/cubeb-core/Cargo.toml b/third_party/rust/cubeb-core/Cargo.toml
new file mode 100644
index 0000000000..3a75b88a37
--- /dev/null
+++ b/third_party/rust/cubeb-core/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "cubeb-core"
+version = "0.10.3"
+authors = ["Dan Glastonbury <dglastonbury@mozilla.com>"]
+description = """
+Common types and definitions for cubeb rust and C bindings. Not intended for direct use.
+"""
+homepage = "https://github.com/mozilla/cubeb-rs"
+keywords = ["cubeb"]
+categories = ["api-bindings"]
+license = "ISC"
+repository = "https://github.com/mozilla/cubeb-rs"
+
+[dependencies.bitflags]
+version = "1.2.0"
+
+[dependencies.cubeb-sys]
+version = "0.10.3"
+
+[features]
+gecko-in-tree = ["cubeb-sys/gecko-in-tree"]
+
+[badges.circle-ci]
+repository = "mozilla/cubeb-rs"