summaryrefslogtreecommitdiffstats
path: root/third_party/rust/line-wrap/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/line-wrap/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/line-wrap/Cargo.toml')
-rw-r--r--third_party/rust/line-wrap/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/third_party/rust/line-wrap/Cargo.toml b/third_party/rust/line-wrap/Cargo.toml
new file mode 100644
index 0000000000..d27efdd654
--- /dev/null
+++ b/third_party/rust/line-wrap/Cargo.toml
@@ -0,0 +1,29 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "line-wrap"
+version = "0.1.1"
+authors = ["Marshall Pierce <marshall@mpierce.org>"]
+description = "Efficiently insert line separators"
+documentation = "https://docs.rs/line-wrap/"
+readme = "README.md"
+keywords = ["line-wrap", "line", "wrap"]
+categories = ["encoding"]
+license = "Apache-2.0"
+repository = "https://bitbucket.org/marshallpierce/line-wrap-rs/src"
+[profile.bench]
+debug = true
+[dependencies.safemem]
+version = "0.3"
+[dev-dependencies.rand]
+version = "0.5.5"