summaryrefslogtreecommitdiffstats
path: root/third_party/rust/minidump-writer/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/minidump-writer/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/minidump-writer/Cargo.toml')
-rw-r--r--third_party/rust/minidump-writer/Cargo.toml94
1 files changed, 94 insertions, 0 deletions
diff --git a/third_party/rust/minidump-writer/Cargo.toml b/third_party/rust/minidump-writer/Cargo.toml
new file mode 100644
index 0000000000..9f84056d6a
--- /dev/null
+++ b/third_party/rust/minidump-writer/Cargo.toml
@@ -0,0 +1,94 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "minidump-writer"
+version = "0.8.0"
+authors = ["Martin Sirringhaus"]
+description = "Rust rewrite of Breakpad's minidump_writer"
+homepage = "https://github.com/rust-minidump/minidump-writer"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/rust-minidump/minidump-writer"
+
+[dependencies.byteorder]
+version = "1.3.2"
+
+[dependencies.cfg-if]
+version = "1.0"
+
+[dependencies.crash-context]
+version = "0.6"
+
+[dependencies.memoffset]
+version = "0.8"
+
+[dependencies.minidump-common]
+version = "0.15"
+
+[dependencies.scroll]
+version = "0.11"
+
+[dependencies.tempfile]
+version = "3.1.0"
+
+[dependencies.thiserror]
+version = "1.0.21"
+
+[dev-dependencies.futures]
+version = "0.3"
+features = ["executor"]
+
+[dev-dependencies.memmap2]
+version = "0.5"
+
+[dev-dependencies.minidump]
+version = "0.15"
+
+[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.nix]
+version = "0.26"
+features = [
+ "mman",
+ "process",
+ "ptrace",
+ "user",
+]
+default-features = false
+
+[target."cfg(target_os = \"macos\")".dependencies.mach2]
+version = "0.4"
+
+[target."cfg(target_os = \"macos\")".dev-dependencies.dump_syms]
+version = "2.0.0"
+default-features = false
+
+[target."cfg(target_os = \"macos\")".dev-dependencies.minidump-processor]
+version = "0.15"
+default-features = false
+
+[target."cfg(target_os = \"macos\")".dev-dependencies.similar-asserts]
+version = "1.2"
+
+[target."cfg(target_os = \"macos\")".dev-dependencies.uuid]
+version = "1.0"
+
+[target."cfg(target_os = \"windows\")".dependencies.bitflags]
+version = "2.0"
+
+[target."cfg(unix)".dependencies.goblin]
+version = "0.6"
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.74"
+
+[target."cfg(unix)".dependencies.memmap2]
+version = "0.5"