summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rust_decimal/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/rust_decimal/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/rust_decimal/Cargo.toml')
-rw-r--r--third_party/rust/rust_decimal/Cargo.toml249
1 files changed, 249 insertions, 0 deletions
diff --git a/third_party/rust/rust_decimal/Cargo.toml b/third_party/rust/rust_decimal/Cargo.toml
new file mode 100644
index 0000000000..1bbbd9ba57
--- /dev/null
+++ b/third_party/rust/rust_decimal/Cargo.toml
@@ -0,0 +1,249 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.60"
+name = "rust_decimal"
+version = "1.28.1"
+authors = ["Paul Mason <paul@form1.co.nz>"]
+build = "build.rs"
+exclude = ["tests/generated/*"]
+description = "Decimal number implementation written in pure Rust suitable for financial and fixed-precision calculations."
+documentation = "https://docs.rs/rust_decimal/"
+readme = "./README.md"
+keywords = [
+ "decimal",
+ "financial",
+ "fixed",
+ "precision",
+ "number",
+]
+categories = [
+ "science",
+ "mathematics",
+ "data-structures",
+]
+license = "MIT"
+repository = "https://github.com/paupino/rust-decimal"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[[bench]]
+name = "comparison"
+path = "benches/comparison.rs"
+harness = false
+
+[dependencies.arbitrary]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.arrayvec]
+version = "0.7"
+default-features = false
+
+[dependencies.borsh]
+version = "0.10.0"
+optional = true
+default-features = false
+
+[dependencies.bytecheck]
+version = "0.6"
+optional = true
+default-features = false
+
+[dependencies.byteorder]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.bytes]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.diesel1]
+version = "1.0"
+optional = true
+default-features = false
+package = "diesel"
+
+[dependencies.diesel2]
+version = "2.0"
+optional = true
+default-features = false
+package = "diesel"
+
+[dependencies.num-traits]
+version = "0.2"
+features = ["i128"]
+default-features = false
+
+[dependencies.postgres]
+version = "0.19"
+optional = true
+default-features = false
+
+[dependencies.rand]
+version = "0.8"
+optional = true
+default-features = false
+
+[dependencies.rkyv]
+version = "0.7"
+features = [
+ "size_32",
+ "std",
+]
+optional = true
+default-features = false
+
+[dependencies.rocket]
+version = "0.5.0-rc.1"
+optional = true
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.tokio-postgres]
+version = "0.7"
+optional = true
+default-features = false
+
+[dev-dependencies.bincode]
+version = "1.0"
+default-features = false
+
+[dev-dependencies.bytes]
+version = "1.0"
+default-features = false
+
+[dev-dependencies.criterion]
+version = "0.4.0"
+default-features = false
+
+[dev-dependencies.csv]
+version = "1"
+
+[dev-dependencies.futures]
+version = "0.3"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+features = ["getrandom"]
+default-features = false
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+default-features = false
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.tokio]
+version = "1.0"
+features = [
+ "macros",
+ "rt-multi-thread",
+ "test-util",
+]
+default-features = false
+
+[dev-dependencies.version-sync]
+version = "0.9"
+features = [
+ "html_root_url_updated",
+ "markdown_deps_updated",
+]
+default-features = false
+
+[features]
+c-repr = []
+db-diesel-mysql = ["db-diesel1-mysql"]
+db-diesel-postgres = ["db-diesel1-postgres"]
+db-diesel1-mysql = [
+ "diesel1/mysql",
+ "std",
+]
+db-diesel1-postgres = [
+ "diesel1/postgres",
+ "std",
+]
+db-diesel2-mysql = [
+ "diesel2/mysql",
+ "std",
+]
+db-diesel2-postgres = [
+ "diesel2/postgres",
+ "std",
+]
+db-postgres = [
+ "byteorder",
+ "bytes",
+ "postgres",
+ "std",
+]
+db-tokio-postgres = [
+ "byteorder",
+ "bytes",
+ "postgres",
+ "std",
+ "tokio-postgres",
+]
+default = [
+ "serde",
+ "std",
+]
+legacy-ops = []
+maths = []
+maths-nopanic = ["maths"]
+rkyv-safe = [
+ "bytecheck",
+ "rkyv/validation",
+]
+rocket-traits = ["rocket"]
+rust-fuzz = ["arbitrary"]
+serde = ["dep:serde"]
+serde-arbitrary-precision = ["serde-with-arbitrary-precision"]
+serde-bincode = ["serde-str"]
+serde-float = ["serde-with-float"]
+serde-str = ["serde-with-str"]
+serde-with-arbitrary-precision = [
+ "serde",
+ "serde_json/arbitrary_precision",
+ "serde_json/std",
+]
+serde-with-float = ["serde"]
+serde-with-str = ["serde"]
+std = [
+ "arrayvec/std",
+ "borsh?/std",
+ "bytecheck?/std",
+ "byteorder?/std",
+ "bytes?/std",
+ "rand?/std",
+ "rkyv?/std",
+ "serde?/std",
+ "serde_json?/std",
+]
+tokio-pg = ["db-tokio-postgres"]