summaryrefslogtreecommitdiffstats
path: root/third_party/rust/sql-support/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/sql-support/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/sql-support/Cargo.toml')
-rw-r--r--third_party/rust/sql-support/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/rust/sql-support/Cargo.toml b/third_party/rust/sql-support/Cargo.toml
new file mode 100644
index 0000000000..b56d6ee9fe
--- /dev/null
+++ b/third_party/rust/sql-support/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "sql-support"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+license = "MPL-2.0"
+
+[dependencies]
+ffi-support = "0.4"
+lazy_static = "1.4"
+log = "0.4"
+tempfile = "3.1.0"
+thiserror = "1.0"
+
+[dependencies.interrupt-support]
+path = "../interrupt"
+
+[dependencies.rusqlite]
+version = "0.28.0"
+features = [
+ "functions",
+ "limits",
+ "bundled",
+ "unlock_notify",
+]
+
+[dev-dependencies.env_logger]
+version = "0.7"
+default-features = false
+
+[build-dependencies.nss_build_common]
+path = "../rc_crypto/nss/nss_build_common"
+
+[features]
+default = []