summaryrefslogtreecommitdiffstats
path: root/third_party/rust/syn/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/syn/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/syn/Cargo.toml')
-rw-r--r--third_party/rust/syn/Cargo.toml147
1 files changed, 147 insertions, 0 deletions
diff --git a/third_party/rust/syn/Cargo.toml b/third_party/rust/syn/Cargo.toml
new file mode 100644
index 0000000000..c2a36013ec
--- /dev/null
+++ b/third_party/rust/syn/Cargo.toml
@@ -0,0 +1,147 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.31"
+name = "syn"
+version = "1.0.107"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+include = [
+ "/benches/**",
+ "/build.rs",
+ "/Cargo.toml",
+ "/LICENSE-APACHE",
+ "/LICENSE-MIT",
+ "/README.md",
+ "/src/**",
+ "/tests/**",
+]
+description = "Parser for Rust source code"
+documentation = "https://docs.rs/syn"
+readme = "README.md"
+keywords = [
+ "macros",
+ "syn",
+]
+categories = [
+ "development-tools::procedural-macro-helpers",
+ "parser-implementations",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/syn"
+
+[package.metadata.docs.rs]
+all-features = true
+targets = ["x86_64-unknown-linux-gnu"]
+rustdoc-args = [
+ "--cfg",
+ "doc_cfg",
+]
+
+[package.metadata.playground]
+features = [
+ "full",
+ "visit",
+ "visit-mut",
+ "fold",
+ "extra-traits",
+]
+
+[lib]
+doc-scrape-examples = false
+
+[[bench]]
+name = "rust"
+harness = false
+required-features = [
+ "full",
+ "parsing",
+]
+
+[[bench]]
+name = "file"
+required-features = [
+ "full",
+ "parsing",
+]
+
+[dependencies.proc-macro2]
+version = "1.0.46"
+default-features = false
+
+[dependencies.quote]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.unicode-ident]
+version = "1.0"
+
+[dev-dependencies.anyhow]
+version = "1.0"
+
+[dev-dependencies.automod]
+version = "1.0"
+
+[dev-dependencies.flate2]
+version = "1.0"
+
+[dev-dependencies.insta]
+version = "1.0"
+
+[dev-dependencies.rayon]
+version = "1.0"
+
+[dev-dependencies.ref-cast]
+version = "1.0"
+
+[dev-dependencies.regex]
+version = "1.0"
+
+[dev-dependencies.reqwest]
+version = "0.11"
+features = ["blocking"]
+
+[dev-dependencies.syn-test-suite]
+version = "0"
+
+[dev-dependencies.tar]
+version = "0.4.16"
+
+[dev-dependencies.termcolor]
+version = "1.0"
+
+[dev-dependencies.walkdir]
+version = "2.1"
+
+[features]
+clone-impls = []
+default = [
+ "derive",
+ "parsing",
+ "printing",
+ "clone-impls",
+ "proc-macro",
+]
+derive = []
+extra-traits = []
+fold = []
+full = []
+parsing = []
+printing = ["quote"]
+proc-macro = [
+ "proc-macro2/proc-macro",
+ "quote/proc-macro",
+]
+test = ["syn-test-suite/all-features"]
+visit = []
+visit-mut = []