summaryrefslogtreecommitdiffstats
path: root/third_party/rust/time-0.1.45/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/time-0.1.45/README.md
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/time-0.1.45/README.md')
-rw-r--r--third_party/rust/time-0.1.45/README.md31
1 files changed, 31 insertions, 0 deletions
diff --git a/third_party/rust/time-0.1.45/README.md b/third_party/rust/time-0.1.45/README.md
new file mode 100644
index 0000000000..f427eb3ea4
--- /dev/null
+++ b/third_party/rust/time-0.1.45/README.md
@@ -0,0 +1,31 @@
+time
+====
+
+Utilities for working with time-related functions in Rust
+
+[![build status](https://github.com/time-rs/time/workflows/Build/badge.svg?branch=v0.1)](https://github.com/time-rs/time/actions?query=branch%3Av0.1)
+[![Documentation](https://docs.rs/time/badge.svg?version=0.1)](https://docs.rs/time/~0.1)
+![rustc 1.21.0](https://img.shields.io/badge/rustc-1.21.0-blue)
+
+## time v0.1.x is Deprecated
+
+The 0.1.x series of this library is deprecated and in maintenance mode. No new
+features will be added. Active development now occurs in the 0.2.x series.
+
+If you need additional functionality that this crate does not provide, check
+out the [`chrono`](https://github.com/chronotope/chrono) crate.
+
+## Usage
+
+Put this in your `Cargo.toml`:
+
+```toml
+[dependencies]
+time = "0.1"
+```
+
+And this in your crate root:
+
+```rust
+extern crate time;
+```