summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wast/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/wast/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wast/Cargo.toml')
-rw-r--r--third_party/rust/wast/Cargo.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/third_party/rust/wast/Cargo.toml b/third_party/rust/wast/Cargo.toml
new file mode 100644
index 0000000000..d420cbc1ad
--- /dev/null
+++ b/third_party/rust/wast/Cargo.toml
@@ -0,0 +1,50 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "wast"
+version = "56.0.0"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+description = """
+Customizable Rust parsers for the WebAssembly Text formats WAT and WAST
+"""
+homepage = "https://github.com/bytecodealliance/wasm-tools/tree/main/crates/wast"
+documentation = "https://docs.rs/wast"
+readme = "README.md"
+license = "Apache-2.0 WITH LLVM-exception"
+repository = "https://github.com/bytecodealliance/wasm-tools/tree/main/crates/wast"
+
+[[test]]
+name = "parse-fail"
+harness = false
+
+[dependencies.leb128]
+version = "0.2.4"
+
+[dependencies.memchr]
+version = "2.4.1"
+
+[dependencies.unicode-width]
+version = "0.1.9"
+
+[dependencies.wasm-encoder]
+version = "0.25.0"
+
+[dev-dependencies.anyhow]
+version = "1.0.58"
+
+[dev-dependencies.rayon]
+version = "1.3"
+
+[features]
+default = ["wasm-module"]
+wasm-module = []