summaryrefslogtreecommitdiffstats
path: root/toolkit/components/mozprotocol/MozProtocolHandler.sys.mjs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /toolkit/components/mozprotocol/MozProtocolHandler.sys.mjs
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/mozprotocol/MozProtocolHandler.sys.mjs')
-rw-r--r--toolkit/components/mozprotocol/MozProtocolHandler.sys.mjs34
1 files changed, 34 insertions, 0 deletions
diff --git a/toolkit/components/mozprotocol/MozProtocolHandler.sys.mjs b/toolkit/components/mozprotocol/MozProtocolHandler.sys.mjs
new file mode 100644
index 0000000000..6629f274d8
--- /dev/null
+++ b/toolkit/components/mozprotocol/MozProtocolHandler.sys.mjs
@@ -0,0 +1,34 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+import { XPCOMUtils } from "resource://gre/modules/XPCOMUtils.sys.mjs";
+
+const { NetUtil } = ChromeUtils.import("resource://gre/modules/NetUtil.jsm");
+
+export function MozProtocolHandler() {
+ XPCOMUtils.defineLazyPreferenceGetter(
+ this,
+ "urlToLoad",
+ "toolkit.mozprotocol.url",
+ "https://www.mozilla.org/about/manifesto/"
+ );
+}
+
+MozProtocolHandler.prototype = {
+ scheme: "moz",
+ defaultPort: -1,
+ protocolFlags: Ci.nsIProtocolHandler.URI_DANGEROUS_TO_LOAD,
+
+ newChannel(uri, loadInfo) {
+ const kCanada = "https://www.mozilla.org/contact/communities/canada/";
+ let realURL = NetUtil.newURI(
+ uri && uri.spec == "moz://eh" ? kCanada : this.urlToLoad
+ );
+ let channel = Services.io.newChannelFromURIWithLoadInfo(realURL, loadInfo);
+ loadInfo.resultPrincipalURI = realURL;
+ return channel;
+ },
+
+ QueryInterface: ChromeUtils.generateQI(["nsIProtocolHandler"]),
+};