summaryrefslogtreecommitdiffstats
path: root/testing/mozbase/mozserve/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mozbase/mozserve/setup.py')
-rw-r--r--testing/mozbase/mozserve/setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/testing/mozbase/mozserve/setup.py b/testing/mozbase/mozserve/setup.py
new file mode 100644
index 0000000000..c00000bb0c
--- /dev/null
+++ b/testing/mozbase/mozserve/setup.py
@@ -0,0 +1,17 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import setup
+
+PACKAGE_VERSION = "0.1"
+
+setup(
+ name="mozserve",
+ version=PACKAGE_VERSION,
+ description="Python test server launcher intended for use with Mozilla testing",
+ long_description="see https://firefox-source-docs.mozilla.org/mozbase/index.html",
+ license="MPL",
+ packages=["mozserve"],
+ zip_safe=False,
+)