summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-001.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-001.html')
-rw-r--r--testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-001.html44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-001.html b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-001.html
new file mode 100644
index 0000000000..f2c5d0a545
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-001.html
@@ -0,0 +1,44 @@
+<!doctype html>
+<title>&lt;link disabled&gt;, HTMLLinkElement.disabled and CSSStyleSheet.disabled interactions</title>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="author" title="Mozilla" href="https://mozilla.org">
+<link rel="help" href="https://html.spec.whatwg.org/#attr-link-disabled">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<link title="alt" rel="stylesheet" disabled href="data:text/css,html { background: green }">
+<script>
+function assert_applies(applies) {
+ (applies ? assert_equals : assert_not_equals)(getComputedStyle(document.documentElement).backgroundColor, "rgb(0, 128, 0)");
+}
+
+const link = document.querySelector("link[disabled]");
+
+test(function() {
+ assert_equals(document.styleSheets.length, 0);
+ assert_applies(false);
+}, "<link disabled> prevents the stylesheet from being in document.styleSheets (from parser)");
+
+async_test(function(t) {
+ assert_true(link.disabled);
+
+ link.onload = t.step_func_done(function() {
+ assert_equals(document.styleSheets.length, 1);
+ let sheet = document.styleSheets[0];
+ assert_equals(sheet.ownerNode, link);
+ assert_applies(true);
+
+ link.disabled = true;
+ assert_equals(sheet.ownerNode, null);
+ assert_false(sheet.disabled);
+ assert_applies(false);
+ assert_true(link.hasAttribute("disabled"));
+
+ assert_equals(document.styleSheets.length, 0);
+ assert_applies(false);
+ });
+
+ link.disabled = false;
+ assert_true(!link.hasAttribute("disabled"));
+ assert_false(link.disabled);
+}, "HTMLLinkElement.disabled reflects the <link disabled> attribute, and behaves consistently");
+</script>