summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cty
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cty')
-rw-r--r--third_party/rust/cty/.cargo-checksum.json1
-rw-r--r--third_party/rust/cty/CHANGELOG.md73
-rw-r--r--third_party/rust/cty/Cargo.toml21
-rw-r--r--third_party/rust/cty/LICENSE-APACHE201
-rw-r--r--third_party/rust/cty/LICENSE-MIT25
-rw-r--r--third_party/rust/cty/README.md22
-rw-r--r--third_party/rust/cty/ci/install.sh7
-rw-r--r--third_party/rust/cty/ci/script.sh10
-rw-r--r--third_party/rust/cty/src/lib.rs136
9 files changed, 496 insertions, 0 deletions
diff --git a/third_party/rust/cty/.cargo-checksum.json b/third_party/rust/cty/.cargo-checksum.json
new file mode 100644
index 0000000000..902714f58a
--- /dev/null
+++ b/third_party/rust/cty/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"CHANGELOG.md":"077c738b5f2c05d66a12209edaabca887091db727d61164a7a414da23d8bf08f","Cargo.toml":"94a517ea6c7dad4634a9a2bd356f3a8035927e7ff8367bd5a975b4db4ccf8e6e","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"035e70219855119df4273b3c5b97543ae82e0dd60c520416e759107c602f651b","README.md":"19687c50697e6abc991e4c35e6d674db56bd5e5ae0d5b833440718f8f154a74d","ci/install.sh":"9b34273d9e79ec59f63d5e3e7aea27b0db66194667f9730a21158740fa1b99f1","ci/script.sh":"54962430ca4d3528e5c0d44ff590b1504be13147db5cbe8bb82f1358528ef5f3","src/lib.rs":"33a38ce6df718fb0191f34ff2cefdcbd3ad9d93f0c4073b78eaf937c07fb7614"},"package":"b365fabc795046672053e29c954733ec3b05e4be654ab130fe8f1f94d7051f35"} \ No newline at end of file
diff --git a/third_party/rust/cty/CHANGELOG.md b/third_party/rust/cty/CHANGELOG.md
new file mode 100644
index 0000000000..26845fbc85
--- /dev/null
+++ b/third_party/rust/cty/CHANGELOG.md
@@ -0,0 +1,73 @@
+# Change Log
+
+All notable changes to this project will be documented in this file.
+This project adheres to $[Semantic Versioning](http://semver.org/).
+
+## [Unreleased]
+
+## [v0.2.2] - 2021-10-09
+
+### Fixed
+
+- fixed `c_char` on ARM64 macOS
+
+## [v0.2.1] - 2019-11-16
+
+### Added
+
+- Support for the `xtensa`, `riscv32` and `riscv64` architectures
+
+## [v0.2.0] - 2019-02-06
+
+### Changed
+
+- [breaking-change] `cty::c_void` is now a type alias of `core::ffi::c_void`.
+
+## [v0.1.5] - 2017-05-29
+
+### Added
+
+- More types like `int32_t`
+
+## [v0.1.4] - 2017-05-29
+
+### Added
+
+- Support for the `msp430` architecture.
+
+### Fixed
+
+- [breaking-change] The type definitions of `c_long` and `c_ulong`.
+
+## [v0.1.3] - 2017-05-29 - YANKED
+
+### Added
+
+- Support for the `nvptx` and `nvptx64` architectures.
+
+## [v0.1.2] - 2017-05-29 - YANKED
+
+### Fixed
+
+- [breaking-change] The type definitions of `c_int` and `c_uint`.
+
+## [v0.1.1] - 2017-05-29 - YANKED
+
+### Fixed
+
+- [breaking-change] The type definitions of `c_long`, `c_ulong` and
+ `c_longlong`.
+
+## v0.1.0 - 2017-05-24 - YANKED
+
+- Initial release
+
+[Unreleased]: https://github.com/japaric/cty/compare/v0.2.2...HEAD
+[v0.2.2]: https://github.com/japaric/cty/compare/v0.2.1...v0.2.2
+[v0.2.1]: https://github.com/japaric/cty/compare/v0.2.0...v0.2.1
+[v0.2.0]: https://github.com/japaric/cty/compare/v0.1.5...v0.2.0
+[v0.1.5]: https://github.com/japaric/cty/compare/v0.1.4...v0.1.5
+[v0.1.4]: https://github.com/japaric/cty/compare/v0.1.3...v0.1.4
+[v0.1.3]: https://github.com/japaric/cty/compare/v0.1.2...v0.1.3
+[v0.1.2]: https://github.com/japaric/cty/compare/v0.1.1...v0.1.2
+[v0.1.1]: https://github.com/japaric/cty/compare/v0.1.0...v0.1.1
diff --git a/third_party/rust/cty/Cargo.toml b/third_party/rust/cty/Cargo.toml
new file mode 100644
index 0000000000..d93a01a127
--- /dev/null
+++ b/third_party/rust/cty/Cargo.toml
@@ -0,0 +1,21 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "cty"
+version = "0.2.2"
+authors = ["Jorge Aparicio <jorge@japaric.io>"]
+description = "Type aliases to C types like c_int for use with bindgen"
+documentation = "https://docs.rs/cty"
+keywords = ["c", "types", "bindgen", "ffi"]
+categories = ["embedded", "external-ffi-bindings", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/japaric/cty"
diff --git a/third_party/rust/cty/LICENSE-APACHE b/third_party/rust/cty/LICENSE-APACHE
new file mode 100644
index 0000000000..16fe87b06e
--- /dev/null
+++ b/third_party/rust/cty/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/cty/LICENSE-MIT b/third_party/rust/cty/LICENSE-MIT
new file mode 100644
index 0000000000..a128ba4022
--- /dev/null
+++ b/third_party/rust/cty/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2017 Jorge Aparicio
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/cty/README.md b/third_party/rust/cty/README.md
new file mode 100644
index 0000000000..f5d09bd499
--- /dev/null
+++ b/third_party/rust/cty/README.md
@@ -0,0 +1,22 @@
+[![crates.io](https://img.shields.io/crates/v/cty.svg)](https://crates.io/crates/cty)
+[![crates.io](https://img.shields.io/crates/d/cty.svg)](https://crates.io/crates/cty)
+
+# `cty`
+
+> Type aliases to C types like c_int for use with bindgen
+
+## License
+
+Licensed under either of
+
+- Apache License, Version 2.0 ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+- MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in the work by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.
diff --git a/third_party/rust/cty/ci/install.sh b/third_party/rust/cty/ci/install.sh
new file mode 100644
index 0000000000..58ed3c9e96
--- /dev/null
+++ b/third_party/rust/cty/ci/install.sh
@@ -0,0 +1,7 @@
+set -ex
+
+main() {
+ return
+}
+
+main
diff --git a/third_party/rust/cty/ci/script.sh b/third_party/rust/cty/ci/script.sh
new file mode 100644
index 0000000000..46ac0c26bc
--- /dev/null
+++ b/third_party/rust/cty/ci/script.sh
@@ -0,0 +1,10 @@
+set -ex
+
+main() {
+ for target in $(rustup target list | grep linux-gnu | cut -d' ' -f1); do
+ rustup target add $target || continue
+ cargo check --target $target
+ done
+}
+
+main
diff --git a/third_party/rust/cty/src/lib.rs b/third_party/rust/cty/src/lib.rs
new file mode 100644
index 0000000000..971c9cb3a9
--- /dev/null
+++ b/third_party/rust/cty/src/lib.rs
@@ -0,0 +1,136 @@
+//! Type aliases to C types like c_int for use with bindgen
+//!
+//! # MSRV
+//!
+//! This crate is guaranteed to compile on stable Rust 1.30.0 and up. It *might* compile with older
+//! versions but that may change in any new patch release.
+
+#![allow(non_camel_case_types)]
+#![deny(warnings)]
+#![no_std]
+
+// AD = Architecture dependent
+pub use ad::*;
+// OD = OS dependent
+pub use od::*;
+// PWD = Pointer Width Dependent
+pub use pwd::*;
+
+#[cfg(any(all(target_arch = "aarch64", not(target_os = "macos")),
+ target_arch = "arm",
+ target_arch = "asmjs",
+ target_arch = "wasm32",
+ target_arch = "wasm64",
+ target_arch = "powerpc",
+ target_arch = "powerpc64",
+ target_arch = "s390x",
+ target_arch = "riscv32",
+ target_arch = "riscv64"))]
+mod ad {
+ pub type c_char = ::c_uchar;
+
+ pub type c_int = i32;
+ pub type c_uint = u32;
+}
+
+// TODO: Once https://github.com/rust-lang/rfcs/pull/2992 lands,
+// this should be extended to cover `aarch64-apple-ios-macabi`.
+#[cfg(all(target_arch = "aarch64", target_os = "macos"))]
+mod ad {
+ pub type c_char = ::c_schar;
+
+ pub type c_int = i32;
+ pub type c_uint = u32;
+}
+
+#[cfg(any(target_arch = "mips",
+ target_arch = "mips64",
+ target_arch = "sparc64",
+ target_arch = "x86",
+ target_arch = "x86_64",
+ target_arch = "nvptx",
+ target_arch = "nvptx64",
+ target_arch = "xtensa"))]
+mod ad {
+ pub type c_char = ::c_schar;
+
+ pub type c_int = i32;
+ pub type c_uint = u32;
+}
+
+#[cfg(target_arch = "msp430")]
+mod ad {
+ pub type c_char = ::c_uchar;
+
+ pub type c_int = i16;
+ pub type c_uint = u16;
+}
+
+// NOTE c_{,u}long definitions come from libc v0.2.3
+#[cfg(not(any(windows,
+ target_os = "redox",
+ target_os = "solaris")))]
+mod od {
+ #[cfg(any(target_pointer_width = "16",
+ target_pointer_width = "32"))]
+ pub type c_long = i32;
+ #[cfg(any(target_pointer_width = "16",
+ target_pointer_width = "32"))]
+ pub type c_ulong = u32;
+
+ #[cfg(target_pointer_width = "64")]
+ pub type c_long = i64;
+ #[cfg(target_pointer_width = "64")]
+ pub type c_ulong = u64;
+}
+
+#[cfg(windows)]
+mod od {
+ pub type c_long = i32;
+ pub type c_ulong = u32;
+}
+
+#[cfg(any(target_os = "redox",
+ target_os = "solaris"))]
+mod od {
+ pub type c_long = i64;
+ pub type c_ulong = u64;
+}
+
+#[cfg(target_pointer_width = "32")]
+mod pwd {}
+
+#[cfg(target_pointer_width = "64")]
+mod pwd {}
+
+pub type int8_t = i8;
+pub type int16_t = i16;
+pub type int32_t = i32;
+pub type int64_t = i64;
+
+pub type uint8_t = u8;
+pub type uint16_t = u16;
+pub type uint32_t = u32;
+pub type uint64_t = u64;
+
+pub type c_schar = i8;
+pub type c_short = i16;
+pub type c_longlong = i64;
+
+pub type c_uchar = u8;
+pub type c_ushort = u16;
+pub type c_ulonglong = u64;
+
+pub type c_float = f32;
+pub type c_double = f64;
+
+pub type intmax_t = i64;
+pub type uintmax_t = u64;
+
+pub type size_t = usize;
+pub type ptrdiff_t = isize;
+pub type intptr_t = isize;
+pub type uintptr_t = usize;
+pub type ssize_t = isize;
+
+pub type c_void = core::ffi::c_void;