summaryrefslogtreecommitdiffstats
path: root/third_party/rust/darling/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/darling/Cargo.toml')
-rw-r--r--third_party/rust/darling/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/third_party/rust/darling/Cargo.toml b/third_party/rust/darling/Cargo.toml
new file mode 100644
index 0000000000..68115fdb63
--- /dev/null
+++ b/third_party/rust/darling/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "darling"
+version = "0.14.3"
+authors = ["Ted Driggs <ted.driggs@outlook.com>"]
+exclude = [
+ "/.travis.yml",
+ "/publish.sh",
+ "/.github/**",
+]
+description = """
+A proc-macro library for reading attributes into structs when
+implementing custom derives.
+"""
+documentation = "https://docs.rs/darling/0.14.3"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/TedDriggs/darling"
+
+[dependencies.darling_core]
+version = "=0.14.3"
+
+[dependencies.darling_macro]
+version = "=0.14.3"
+
+[dev-dependencies.proc-macro2]
+version = "1.0.37"
+
+[dev-dependencies.quote]
+version = "1.0.18"
+
+[dev-dependencies.syn]
+version = "1.0.91"
+
+[features]
+default = ["suggestions"]
+diagnostics = ["darling_core/diagnostics"]
+suggestions = ["darling_core/suggestions"]
+
+[target."cfg(compiletests)".dev-dependencies.rustversion]
+version = "1.0.9"
+
+[target."cfg(compiletests)".dev-dependencies.trybuild]
+version = "1.0.38"
+
+[badges.maintenance]
+status = "actively-developed"