summaryrefslogtreecommitdiffstats
path: root/third_party/rust/dns-parser/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/dns-parser/Cargo.toml')
-rw-r--r--third_party/rust/dns-parser/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/third_party/rust/dns-parser/Cargo.toml b/third_party/rust/dns-parser/Cargo.toml
new file mode 100644
index 0000000000..085abfb82a
--- /dev/null
+++ b/third_party/rust/dns-parser/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "dns-parser"
+version = "0.8.0"
+authors = ["Paul Colomiets <paul@colomiets.name>"]
+description = " Pure-rust DNS protocol parser library. This does not support network, only\n raw protocol parser.\n"
+homepage = "https://github.com/tailhook/dns-parser"
+documentation = "https://docs.rs/dns-parser"
+readme = "README.md"
+keywords = ["dns", "domain", "name", "parser"]
+categories = ["parser-implementations"]
+license = "MIT/Apache-2.0"
+[dependencies.byteorder]
+version = "1"
+
+[dependencies.quick-error]
+version = "1.0.0"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dependencies.serde_derive]
+version = "1.0"
+optional = true
+[dev-dependencies.matches]
+version = "0.1.2"
+
+[features]
+with-serde = ["serde", "serde_derive"]