summaryrefslogtreecommitdiffstats
path: root/third_party/rust/glsl/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/glsl/Cargo.toml')
-rw-r--r--third_party/rust/glsl/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/glsl/Cargo.toml b/third_party/rust/glsl/Cargo.toml
new file mode 100644
index 0000000000..8d31a8599b
--- /dev/null
+++ b/third_party/rust/glsl/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "glsl"
+version = "6.0.2"
+authors = ["Dimitri Sabadie <dimitri.sabadie@gmail.com>"]
+description = "A GLSL450/GLSL460 parser."
+homepage = "https://github.com/phaazon/glsl"
+documentation = "https://docs.rs/glsl"
+readme = "README.md"
+keywords = [
+ "GLSL",
+ "OpenGL",
+ "SPIR-V",
+ "parser",
+]
+categories = [
+ "parsing",
+ "rendering",
+]
+license = "BSD-3-Clause"
+repository = "https://github.com/phaazon/glsl"
+
+[dependencies.nom]
+version = "7"
+features = ["std"]
+default-features = false
+
+[dependencies.shaderc]
+version = "0.6"
+optional = true
+
+[features]
+spirv = ["shaderc"]