summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-common/Cargo.toml')
-rw-r--r--third_party/rust/neqo-common/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/neqo-common/Cargo.toml b/third_party/rust/neqo-common/Cargo.toml
new file mode 100644
index 0000000000..93c58fe25f
--- /dev/null
+++ b/third_party/rust/neqo-common/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.57.0"
+name = "neqo-common"
+version = "0.6.4"
+authors = ["Bobby Holley <bobbyholley@gmail.com>"]
+build = "build.rs"
+license = "MIT/Apache-2.0"
+
+[dependencies]
+lazy_static = "1.3.0"
+qlog = "0.4.0"
+
+[dependencies.chrono]
+version = "0.4.10"
+features = ["std"]
+default-features = false
+
+[dependencies.env_logger]
+version = "0.9"
+default-features = false
+
+[dependencies.log]
+version = "0.4.0"
+default-features = false
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["timeapi"]