summaryrefslogtreecommitdiffstats
path: root/third_party/rust/unix_path/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/unix_path/Cargo.toml')
-rw-r--r--third_party/rust/unix_path/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/unix_path/Cargo.toml b/third_party/rust/unix_path/Cargo.toml
new file mode 100644
index 0000000000..eb132b4cb5
--- /dev/null
+++ b/third_party/rust/unix_path/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "unix_path"
+version = "1.0.1"
+authors = ["SnejUgal <contact@snejugal.ru>"]
+description = "Unix-compatible paths regardless of platform."
+readme = "./Readme.md"
+keywords = ["unix", "path", "pathbuf"]
+categories = ["no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://gitlab.com/SnejUgal/unix_path"
+[dependencies.serde]
+version = "1"
+optional = true
+
+[dependencies.unix_str]
+version = "1"
+default-features = false
+
+[features]
+alloc = ["unix_str/alloc"]
+default = ["std"]
+shrink_to = ["unix_str/shrink_to"]
+std = ["alloc", "unix_str/std"]