summaryrefslogtreecommitdiffstats
path: root/third_party/rust/weedle2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/weedle2/Cargo.toml')
-rw-r--r--third_party/rust/weedle2/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/weedle2/Cargo.toml b/third_party/rust/weedle2/Cargo.toml
new file mode 100644
index 0000000000..072d3f9a2a
--- /dev/null
+++ b/third_party/rust/weedle2/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "weedle2"
+version = "4.0.0"
+authors = [
+ "Sharad Chand <sharad.d.chand@gmail.com>",
+ "Jan-Erik Rediger <jrediger@mozilla.com>",
+]
+exclude = ["tests"]
+description = "A WebIDL Parser"
+homepage = "https://github.com/mozilla/uniffi-rs/tree/main/weedle2"
+documentation = "https://docs.rs/weedle2"
+readme = "./README.md"
+license = "MIT"
+repository = "https://github.com/mozilla/uniffi-rs"
+resolver = "2"
+
+[lib]
+name = "weedle"
+
+[dependencies.nom]
+version = "7.1.0"
+
+[dev-dependencies.fs-err]
+version = "2.7.0"