summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/changelog12
-rw-r--r--debian/patches/screencast-Correct-expected-bus-name-for-streams.patch29
-rw-r--r--debian/patches/series1
3 files changed, 42 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 35648e0..5adcaf1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+gnome-shell (43.9-0+deb12u2) bookworm-security; urgency=high
+
+ * d/p/screencast-Correct-expected-bus-name-for-streams.patch:
+ Avoid screencast regression after fixing CVE-2024-34397.
+ Previously, screencasting expected signals to come from the wrong
+ D-Bus name, which only worked because there was a vulnerability in
+ GLib that resulted in the sender being ignored.
+ * Set urgency=high because this fixes a regression triggered by a
+ security fix.
+
+ -- Simon McVittie <smcv@debian.org> Mon, 06 May 2024 22:13:19 +0100
+
gnome-shell (43.9-0+deb12u1progress7u1) graograman; urgency=medium
* Initial reupload to graograman.
diff --git a/debian/patches/screencast-Correct-expected-bus-name-for-streams.patch b/debian/patches/screencast-Correct-expected-bus-name-for-streams.patch
new file mode 100644
index 0000000..85c5819
--- /dev/null
+++ b/debian/patches/screencast-Correct-expected-bus-name-for-streams.patch
@@ -0,0 +1,29 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Mon, 6 May 2024 21:58:09 +0100
+Subject: screencast: Correct expected bus name for streams
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Previously, this only worked because GDBusConnection was not filtering
+signals by their sender correctly (GNOME/glib#3268).
+
+Thanks: Alicia Boya GarcĂ­a
+Signed-off-by: Simon McVittie <smcv@debian.org>
+---
+ js/dbusServices/screencast/screencastService.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/js/dbusServices/screencast/screencastService.js b/js/dbusServices/screencast/screencastService.js
+index eb3dc88..901af34 100644
+--- a/js/dbusServices/screencast/screencastService.js
++++ b/js/dbusServices/screencast/screencastService.js
+@@ -167,7 +167,7 @@ var Recorder = class {
+ });
+
+ this._streamProxy = new ScreenCastStreamProxy(Gio.DBus.session,
+- 'org.gnome.ScreenCast.Stream',
++ 'org.gnome.Mutter.ScreenCast',
+ streamPath);
+
+ this._streamProxy.connectSignal('PipeWireStreamAdded',
diff --git a/debian/patches/series b/debian/patches/series
index 917d008..e0f5d47 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
overview-Handle-unredirection-in-OverviewShown-state-mach.patch
debian/gnome-shell-extension-prefs-Give-Debian-specific-advice.patch
debian/Revert-build-Port-to-gcr4.patch
+screencast-Correct-expected-bus-name-for-streams.patch