summaryrefslogtreecommitdiffstats
path: root/cppu/Module_cppu.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /cppu/Module_cppu.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cppu/Module_cppu.mk')
-rw-r--r--cppu/Module_cppu.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/cppu/Module_cppu.mk b/cppu/Module_cppu.mk
new file mode 100644
index 000000000..17f6936f7
--- /dev/null
+++ b/cppu/Module_cppu.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,cppu))
+
+$(eval $(call gb_Module_add_targets,cppu,\
+ InternalUnoApi_cppu_qa_cppumaker_types \
+ InternalUnoApi_cppu_qa_types \
+ Library_affine_uno_uno \
+ Library_cppu \
+ Library_log_uno_uno \
+ Library_purpenvhelper \
+ Library_unsafe_uno_uno \
+))
+
+$(eval $(call gb_Module_add_check_targets,cppu,\
+ CppunitTest_cppu_any-external \
+ CppunitTest_cppu_qa_any \
+ CppunitTest_cppu_qa_recursion \
+ CppunitTest_cppu_qa_reference \
+ CppunitTest_cppu_qa_unotype \
+ CppunitTest_cppu_test_cppumaker \
+ CppunitTest_cppu_typelib \
+))
+
+# vim: set noet sw=4 ts=4: