summaryrefslogtreecommitdiffstats
path: root/odk/examples/cpp/Convertor
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /odk/examples/cpp/Convertor
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/examples/cpp/Convertor')
-rw-r--r--odk/examples/cpp/Convertor/Convertor.cxx116
-rw-r--r--odk/examples/cpp/Convertor/Makefile83
-rw-r--r--odk/examples/cpp/Convertor/test.odtbin0 -> 11176 bytes
3 files changed, 199 insertions, 0 deletions
diff --git a/odk/examples/cpp/Convertor/Convertor.cxx b/odk/examples/cpp/Convertor/Convertor.cxx
new file mode 100644
index 000000000..765a28317
--- /dev/null
+++ b/odk/examples/cpp/Convertor/Convertor.cxx
@@ -0,0 +1,116 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4; fill-column: 100 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ */
+
+#include <iostream>
+#include <sal/main.h>
+#include <cppuhelper/bootstrap.hxx>
+#include <rtl/bootstrap.hxx>
+
+#include <osl/file.hxx>
+#include <osl/process.h>
+#include <rtl/process.h>
+
+#include <com/sun/star/beans/XPropertySet.hpp>
+#include <com/sun/star/bridge/XUnoUrlResolver.hpp>
+#include <com/sun/star/frame/Desktop.hpp>
+#include <com/sun/star/frame/XComponentLoader.hpp>
+#include <com/sun/star/frame/XStorable.hpp>
+#include <com/sun/star/lang/XMultiComponentFactory.hpp>
+#include <com/sun/star/text/XTextDocument.hpp>
+
+using namespace cppu;
+using namespace rtl;
+using namespace css::uno;
+using namespace css::beans;
+using namespace css::bridge;
+using namespace css::frame;
+using namespace css::lang;
+using namespace css::text;
+
+SAL_IMPLEMENT_MAIN_WITH_ARGS(argc, argv)
+{
+ OUString sInputFileName, sOutputFileName;
+ OUString sConnectionString("uno:socket,host=localhost,port=2083;urp;StarOffice.ServiceManager");
+
+ sal_Int32 nCount = rtl_getAppCommandArgCount();
+
+ if (nCount < 1)
+ {
+ std::cout
+ << "using: Convertor -env:URE_MORE_TYPES=<office_types_rdb_url> <file_url> "
+ "[<uno_connection_url>]"
+ << std::endl
+ << std::endl
+ << "example: Convertor -env:URE_MORE_TYPES=\"file:///.../program/offapi.rdb\" test.odt"
+ "\"uno:socket,host=localhost,port=2083;urp;StarOffice.ServiceManager\""
+ << std::endl;
+ exit(1);
+ }
+
+ auto xComponentContext(defaultBootstrap_InitialComponentContext());
+ auto xMultiComponentFactoryClient(xComponentContext->getServiceManager());
+ auto xInterface = xMultiComponentFactoryClient->createInstanceWithContext(
+ "com.sun.star.bridge.UnoUrlResolver", xComponentContext);
+ auto resolver = Reference<XUnoUrlResolver>(xInterface, UNO_QUERY);
+ try
+ {
+ xInterface = Reference<XInterface>(resolver->resolve(sConnectionString), UNO_QUERY_THROW);
+ }
+ catch (Exception& e)
+ {
+ std::cout << "Error: cannot establish a connection using '" << sConnectionString << "'"
+ << std::endl
+ << e.Message << std::endl;
+ std::exit(1);
+ }
+
+ auto xPropSet = Reference<XPropertySet>(xInterface, UNO_QUERY);
+ xPropSet->getPropertyValue("DefaultContext") >>= xComponentContext;
+ auto xMultiComponentFactoryServer(xComponentContext->getServiceManager());
+ auto xComponentLoader = Desktop::create(xComponentContext);
+ Sequence<PropertyValue> loadProperties(1);
+ loadProperties[0].Name = "Hidden";
+ loadProperties[0].Value <<= true;
+ try
+ {
+ OUString sInputUrl, sAbsoluteInputUrl, sOutputUrl, sAbsoluteOutputUrl, sWorkingDir;
+ osl_getProcessWorkingDir(&sWorkingDir.pData);
+ rtl_getAppCommandArg(0, &sInputFileName.pData);
+
+ osl::FileBase::getFileURLFromSystemPath(sInputFileName, sInputUrl);
+ osl::FileBase::getAbsoluteFileURL(sWorkingDir, sInputUrl, sAbsoluteInputUrl);
+ std::cout << sAbsoluteInputUrl << std::endl;
+
+ osl::FileBase::getFileURLFromSystemPath("output.pdf", sOutputUrl);
+ osl::FileBase::getAbsoluteFileURL(sWorkingDir, sOutputUrl, sAbsoluteOutputUrl);
+ std::cout << sAbsoluteOutputUrl << std::endl;
+
+ auto xComponent = xComponentLoader->loadComponentFromURL(sAbsoluteInputUrl, "_blank", 0,
+ loadProperties);
+ auto xDocument = Reference<XTextDocument>(xComponent, UNO_QUERY_THROW);
+ auto xStorable = Reference<XStorable>(xDocument, UNO_QUERY_THROW);
+ auto storeProps = Sequence<PropertyValue>(3);
+ storeProps[0].Name = "FilterName";
+ storeProps[0].Value <<= OUString("writer_pdf_Export");
+ storeProps[1].Name = "Overwrite";
+ storeProps[1].Value <<= true;
+ storeProps[2].Name = "SelectPdfVersion";
+ storeProps[2].Value <<= sal_Int32(1);
+ xStorable->storeToURL(sAbsoluteOutputUrl, storeProps);
+ Reference<XComponent>::query(xMultiComponentFactoryClient)->dispose();
+ std::cout << "Output output.pdf generated." << std::endl;
+ }
+ catch (Exception& e)
+ {
+ std::cout << "Can not open the input file." << std::endl << e.Message << std::endl;
+ }
+ return 0;
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/odk/examples/cpp/Convertor/Makefile b/odk/examples/cpp/Convertor/Makefile
new file mode 100644
index 000000000..32bec8f7d
--- /dev/null
+++ b/odk/examples/cpp/Convertor/Makefile
@@ -0,0 +1,83 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+# Builds the C++ Convertor example of the SDK.
+
+PRJ=../../..
+SETTINGS=$(PRJ)/settings
+
+include $(SETTINGS)/settings.mk
+include $(SETTINGS)/std.mk
+
+# Define non-platform/compiler specific settings
+COMPONENT_NAME=Convertor
+
+OUT_COMP_INC = $(OUT_INC)/$(COMPONENT_NAME)
+OUT_COMP_GEN = $(OUT_MISC)/$(COMPONENT_NAME)
+OUT_COMP_OBJ=$(OUT_OBJ)/$(COMPONENT_NAME)
+
+CXXFILES = Convertor.cxx
+
+OBJFILES = $(patsubst %.cxx,$(OUT_SLO_COMP)/%.$(OBJ_EXT),$(CXXFILES))
+
+ENV_OFFICE_TYPES=-env:URE_MORE_TYPES=$(URLPREFIX)$(OFFICE_TYPES)
+
+# Targets
+.PHONY: ALL
+ALL : \
+ CppConvertorExample
+
+include $(SETTINGS)/stdtarget.mk
+
+$(OUT_COMP_OBJ)/%.$(OBJ_EXT) : %.cxx $(SDKTYPEFLAG)
+ -$(MKDIR) $(subst /,$(PS),$(@D))
+ $(CC) $(CC_FLAGS) $(CC_INCLUDES) -I$(OUT_COMP_INC) $(CC_DEFINES) $(CC_OUTPUT_SWITCH)$(subst /,$(PS),$@) $<
+
+$(OUT_BIN)/Convertor$(EXE_EXT) : $(OUT_COMP_OBJ)/Convertor.$(OBJ_EXT)
+ -$(MKDIR) $(subst /,$(PS),$(@D))
+ -$(MKDIR) $(subst /,$(PS),$(OUT_COMP_GEN))
+ifeq "$(OS)" "WIN"
+ $(LINK) $(EXE_LINK_FLAGS) /OUT:$@ /MAP:$(OUT_COMP_GEN)/$(basename $(@F)).map \
+ $< $(CPPUHELPERLIB) $(CPPULIB) $(SALHELPERLIB) $(SALLIB)
+else
+ $(LINK) $(EXE_LINK_FLAGS) $(LINK_LIBS) -o $@ $< \
+ $(CPPUHELPERLIB) $(CPPULIB) $(SALHELPERLIB) $(SALLIB) $(STDC++LIB)
+ifeq "$(OS)" "MACOSX"
+ $(INSTALL_NAME_URELIBS_BIN) $@
+endif
+endif
+
+CppConvertorExample : $(OUT_BIN)/Convertor$(EXE_EXT)
+ @echo --------------------------------------------------------------------------------
+ @echo The example loads the "$(QM)test.odt$(QM)" document in the Convertor example directory
+ @echo and convert it to test.pdf
+ @echo -
+ @echo Use the following command to execute the example!
+ @echo -
+ @echo $(MAKE) Convertor.run
+ @echo -
+ @echo NOTE: This example does not use the new UNO bootstrap mechanism, it uses still a socket
+ @echo $(SQM) $(SQM)connection. The example use the defaultBootstrap_InitialComponentContext method and provides
+ @echo $(SQM) $(SQM)the additional office types via the UNO environment variable -env:URE_MORE_TYPES=...
+ @echo $(SQM) $(SQM)Before you can run this example you have to start your office in listening mode.
+ @echo -
+ @echo $(SQM) $(SQM)soffice "$(QM)--accept=socket,host=localhost,port=2083;urp;StarOffice.ServiceManager$(QM)"
+ @echo --------------------------------------------------------------------------------
+
+%.run: $(OUT_BIN)/Convertor$(EXE_EXT)
+ cd $(subst /,$(PS),$(OUT_BIN)) && $(basename $@) $(ENV_OFFICE_TYPES) $(subst \\,/,$(subst /,$(PS),"$(OO_SDK_HOME)/examples/cpp/Convertor/test.odt"))
+
+.PHONY: clean
+clean :
+ -$(DELRECURSIVE) $(subst /,$(PS),$(OUT_COMP_INC))
+ -$(DELRECURSIVE) $(subst /,$(PS),$(OUT_COMP_GEN))
+ -$(DELRECURSIVE) $(subst /,$(PS),$(OUT_COMP_OBJ))
+ -$(DEL) $(subst \\,\,$(subst /,$(PS),$(OUT_BIN)/Convertor*))
+
+# vim: set noet sw=4 ts=4:
diff --git a/odk/examples/cpp/Convertor/test.odt b/odk/examples/cpp/Convertor/test.odt
new file mode 100644
index 000000000..dc4efecac
--- /dev/null
+++ b/odk/examples/cpp/Convertor/test.odt
Binary files differ