summaryrefslogtreecommitdiffstats
path: root/arch/x86/hyperv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/x86/hyperv/Makefile')
-rw-r--r--arch/x86/hyperv/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/arch/x86/hyperv/Makefile b/arch/x86/hyperv/Makefile
new file mode 100644
index 000000000..5d2de1080
--- /dev/null
+++ b/arch/x86/hyperv/Makefile
@@ -0,0 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
+obj-y := hv_init.o mmu.o nested.o irqdomain.o ivm.o
+obj-$(CONFIG_X86_64) += hv_apic.o hv_proc.o
+
+ifdef CONFIG_X86_64
+obj-$(CONFIG_PARAVIRT_SPINLOCKS) += hv_spinlock.o
+endif