summaryrefslogtreecommitdiffstats
path: root/arch/x86/ia32/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/x86/ia32/Makefile')
-rw-r--r--arch/x86/ia32/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/arch/x86/ia32/Makefile b/arch/x86/ia32/Makefile
new file mode 100644
index 000000000..e48105669
--- /dev/null
+++ b/arch/x86/ia32/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the ia32 kernel emulation subsystem.
+#
+
+obj-$(CONFIG_IA32_EMULATION) := ia32_signal.o
+
+audit-class-$(CONFIG_AUDIT) := audit.o
+obj-$(CONFIG_IA32_EMULATION) += $(audit-class-y)