summaryrefslogtreecommitdiffstats
path: root/arch/x86/net/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/x86/net/Makefile')
-rw-r--r--arch/x86/net/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/arch/x86/net/Makefile b/arch/x86/net/Makefile
new file mode 100644
index 000000000..383c87300
--- /dev/null
+++ b/arch/x86/net/Makefile
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Arch-specific network modules
+#
+
+ifeq ($(CONFIG_X86_32),y)
+ obj-$(CONFIG_BPF_JIT) += bpf_jit_comp32.o
+else
+ obj-$(CONFIG_BPF_JIT) += bpf_jit_comp.o
+endif