summaryrefslogtreecommitdiffstats
path: root/drivers/net/can/c_can/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/net/can/c_can/Makefile')
-rw-r--r--drivers/net/can/c_can/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/net/can/c_can/Makefile b/drivers/net/can/c_can/Makefile
new file mode 100644
index 000000000..6fa3b2b9e
--- /dev/null
+++ b/drivers/net/can/c_can/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the Bosch C_CAN controller drivers.
+#
+
+obj-$(CONFIG_CAN_C_CAN) += c_can.o
+
+c_can-objs :=
+c_can-objs += c_can_ethtool.o
+c_can-objs += c_can_main.o
+
+obj-$(CONFIG_CAN_C_CAN_PLATFORM) += c_can_platform.o
+obj-$(CONFIG_CAN_C_CAN_PCI) += c_can_pci.o