summaryrefslogtreecommitdiffstats
path: root/drivers/staging/rtl8192u/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/staging/rtl8192u/Makefile')
-rw-r--r--drivers/staging/rtl8192u/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/drivers/staging/rtl8192u/Makefile b/drivers/staging/rtl8192u/Makefile
new file mode 100644
index 000000000..d32dfd89a
--- /dev/null
+++ b/drivers/staging/rtl8192u/Makefile
@@ -0,0 +1,27 @@
+# SPDX-License-Identifier: GPL-2.0
+NIC_SELECT = RTL8192U
+
+ccflags-y += -DCONFIG_FORCE_HARD_FLOAT=y
+ccflags-y += -DJACKSON_NEW_8187 -DJACKSON_NEW_RX
+ccflags-y += -DTHOMAS_BEACON -DTHOMAS_TASKLET -DTHOMAS_SKB -DTHOMAS_TURBO
+
+r8192u_usb-y := r8192U_core.o r8180_93cx6.o r8192U_wx.o \
+ r8190_rtl8256.o r819xU_phy.o r819xU_firmware.o \
+ r819xU_cmdpkt.o r8192U_dm.o r819xU_firmware_img.o \
+ r8192U_debugfs.o \
+ ieee80211/ieee80211_crypt.o \
+ ieee80211/ieee80211_crypt_tkip.o \
+ ieee80211/ieee80211_crypt_ccmp.o \
+ ieee80211/ieee80211_crypt_wep.o \
+ ieee80211/ieee80211_rx.o \
+ ieee80211/ieee80211_softmac.o \
+ ieee80211/ieee80211_tx.o \
+ ieee80211/ieee80211_wx.o \
+ ieee80211/ieee80211_module.o \
+ ieee80211/ieee80211_softmac_wx.o \
+ ieee80211/rtl819x_HTProc.o \
+ ieee80211/rtl819x_TSProc.o \
+ ieee80211/rtl819x_BAProc.o \
+ ieee80211/dot11d.o
+
+obj-$(CONFIG_RTL8192U) += r8192u_usb.o