summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 18:51:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 18:51:17 +0000
commit130caa6d7ce6d4e4bbb8ea7165eee1fb9346392c (patch)
treec49c7b207a635fe69e59fd70c2670ff33935ea95
parentMerging upstream version 252.23. (diff)
downloadsystemd-debian/252.23-1_deb12u1.tar.xz
systemd-debian/252.23-1_deb12u1.zip
Adding debian version 252.23-1~deb12u1.debian/252.23-1_deb12u1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch4
-rw-r--r--debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch2
-rw-r--r--debian/patches/p11kit-switch-to-dlopen.patch8
4 files changed, 14 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 9fb3ac5..2b71275 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+systemd (252.23-1~deb12u1) bookworm; urgency=medium
+
+ * New upstream version 252.23 (CVE-2023-50387, CVE-2023-50868)
+ * Refresh patches
+
+ -- Luca Boccassi <bluca@debian.org> Wed, 28 Feb 2024 17:00:53 +0000
+
systemd (252.22-1~deb12u1) bookworm; urgency=medium
* d/t/control: add dependency on stress for upstream suite. Needed by
diff --git a/debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch b/debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch
index 1b3ba16..dbbd56f 100644
--- a/debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch
+++ b/debian/patches/debian/Downgrade-a-couple-of-warnings-to-debug.patch
@@ -16,7 +16,7 @@ Closes: #981407
3 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/src/core/load-fragment.c b/src/core/load-fragment.c
-index 1001faa..555492e 100644
+index 5f4d4b0..cf5e55f 100644
--- a/src/core/load-fragment.c
+++ b/src/core/load-fragment.c
@@ -543,6 +543,7 @@ static int patch_var_run(
@@ -51,7 +51,7 @@ index 3c5df6c..24eff86 100644
"Please update package to include a native systemd unit file, in order to make it more safe and robust.", fpath);
diff --git a/src/tmpfiles/tmpfiles.c b/src/tmpfiles/tmpfiles.c
-index 9c3d994..15180a5 100644
+index 281284c..8952a26 100644
--- a/src/tmpfiles/tmpfiles.c
+++ b/src/tmpfiles/tmpfiles.c
@@ -2991,6 +2991,7 @@ static int specifier_expansion_from_arg(const Specifier *specifier_table, Item *
diff --git a/debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch b/debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch
index 103b44a..ec8985c 100644
--- a/debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch
+++ b/debian/patches/debian/fsckd-daemon-for-inter-fsckd-communication.patch
@@ -239,7 +239,7 @@ index 0000000..b7ad58d
+
+</refentry>
diff --git a/meson.build b/meson.build
-index 27d95e7..9ace3e6 100644
+index e707742..6330645 100644
--- a/meson.build
+++ b/meson.build
@@ -3368,6 +3368,15 @@ executable(
diff --git a/debian/patches/p11kit-switch-to-dlopen.patch b/debian/patches/p11kit-switch-to-dlopen.patch
index b22bf58..ed9cbf2 100644
--- a/debian/patches/p11kit-switch-to-dlopen.patch
+++ b/debian/patches/p11kit-switch-to-dlopen.patch
@@ -13,7 +13,7 @@ Subject: p11kit: switch to dlopen()
7 files changed, 202 insertions(+), 60 deletions(-)
diff --git a/meson.build b/meson.build
-index 9de2309..27d95e7 100644
+index afcb4a7..e707742 100644
--- a/meson.build
+++ b/meson.build
@@ -1462,8 +1462,10 @@ if want_p11kit != 'false' and not skip_deps
@@ -718,10 +718,10 @@ index 85dbb81..55728c2 100644
}
diff --git a/test/test-functions b/test/test-functions
-index 73fbef8..0ba7ce2 100644
+index da17bff..58257d4 100644
--- a/test/test-functions
+++ b/test/test-functions
-@@ -1386,7 +1386,7 @@ install_missing_libraries() {
+@@ -1391,7 +1391,7 @@ install_missing_libraries() {
local lib path
# A number of dependencies is now optional via dlopen, so the install
# script will not pick them up, since it looks at linkage.
@@ -730,7 +730,7 @@ index 73fbef8..0ba7ce2 100644
ddebug "Searching for $lib via pkg-config"
if pkg-config --exists "$lib"; then
path="$(pkg-config --variable=libdir "$lib")"
-@@ -1398,6 +1398,10 @@ install_missing_libraries() {
+@@ -1403,6 +1403,10 @@ install_missing_libraries() {
if ! [[ ${lib} =~ ^lib ]]; then
lib="lib${lib}"
fi