summaryrefslogtreecommitdiffstats
path: root/debian/patches/disable-crypto.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:46:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:46:10 +0000
commit7050cdb205fd1b1b847c148092a8548f00a061c0 (patch)
tree05a497ffd12f14405445c3288085e228f4e8579f /debian/patches/disable-crypto.patch
parentAdding upstream version 16.2.11+ds. (diff)
downloadceph-7050cdb205fd1b1b847c148092a8548f00a061c0.tar.xz
ceph-7050cdb205fd1b1b847c148092a8548f00a061c0.zip
Adding debian version 16.2.11+ds-2.debian/16.2.11+ds-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/disable-crypto.patch')
-rw-r--r--debian/patches/disable-crypto.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/patches/disable-crypto.patch b/debian/patches/disable-crypto.patch
new file mode 100644
index 000000000..b25aaac1b
--- /dev/null
+++ b/debian/patches/disable-crypto.patch
@@ -0,0 +1,16 @@
+Index: ceph/src/os/CMakeLists.txt
+===================================================================
+--- ceph.orig/src/os/CMakeLists.txt
++++ ceph/src/os/CMakeLists.txt
+@@ -98,8 +98,9 @@ endif()
+ target_link_libraries(os kv)
+
+ add_dependencies(os compressor_plugins)
+-add_dependencies(os crypto_plugins)
+-
++if(HAVE_INTEL AND HAVE_BETTER_YASM_ELF64 AND (NOT APPLE))
++ add_dependencies(os crypto_plugins)
++endif()
+
+ if(WITH_BLUESTORE)
+ add_executable(ceph-bluestore-tool