summaryrefslogtreecommitdiffstats
path: root/make-srpm.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /make-srpm.sh
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'make-srpm.sh')
-rwxr-xr-xmake-srpm.sh11
1 files changed, 11 insertions, 0 deletions
diff --git a/make-srpm.sh b/make-srpm.sh
new file mode 100755
index 000000000..1ba0ff088
--- /dev/null
+++ b/make-srpm.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+#
+# Create a SRPM which can be used to build Ceph
+#
+# ./make-srpm.sh <version>
+# rpmbuild --rebuild /tmp/ceph/ceph-<version>-0.el7.centos.src.rpm
+#
+
+./make-dist $1
+rpmbuild -D"_sourcedir `pwd`" -D"_specdir `pwd`" -D"_srcrpmdir `pwd`" -bs ceph.spec