summaryrefslogtreecommitdiffstats
path: root/selinux/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /selinux/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'selinux/CMakeLists.txt')
-rw-r--r--selinux/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/selinux/CMakeLists.txt b/selinux/CMakeLists.txt
new file mode 100644
index 000000000..d0a7e54fb
--- /dev/null
+++ b/selinux/CMakeLists.txt
@@ -0,0 +1,11 @@
+add_custom_target(
+ ceph.pp ALL
+ COMMAND ln -sf ${CMAKE_CURRENT_SOURCE_DIR}/ceph.* .
+ COMMAND make -f ${SELINUX_MAKEFILE} ceph.pp
+ DEPENDS ceph.te ceph.fc ceph.if)
+
+set(datadir ${CMAKE_INSTALL_PREFIX}/share/selinux)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ceph.pp
+ DESTINATION ${datadir}/packages)
+install(FILES ceph.if
+ DESTINATION ${datadir}/devel/include/contrib)