summaryrefslogtreecommitdiffstats
path: root/src/arch/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/arch/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/arch/CMakeLists.txt')
-rw-r--r--src/arch/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/arch/CMakeLists.txt b/src/arch/CMakeLists.txt
new file mode 100644
index 000000000..b23862854
--- /dev/null
+++ b/src/arch/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(arch_srcs
+ probe.cc)
+
+if(HAVE_ARM)
+ list(APPEND arch_srcs arm.c)
+elseif(HAVE_INTEL)
+ list(APPEND arch_srcs intel.c)
+elseif(HAVE_POWER8)
+ list(APPEND arch_srcs ppc.c)
+endif()
+
+add_library(arch STATIC ${arch_srcs})