summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/atomic/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/boost/libs/atomic/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/atomic/CMakeLists.txt')
-rw-r--r--src/boost/libs/atomic/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/boost/libs/atomic/CMakeLists.txt b/src/boost/libs/atomic/CMakeLists.txt
new file mode 100644
index 000000000..0511c6470
--- /dev/null
+++ b/src/boost/libs/atomic/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright 2018 Mike Dev
+# Copyright 2019 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5...3.16)
+project(boost_atomic VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
+
+add_library(boost_atomic src/lock_pool.cpp)
+add_library(Boost::atomic ALIAS boost_atomic)
+
+target_include_directories(boost_atomic PUBLIC include)
+
+target_link_libraries(boost_atomic
+ PUBLIC
+ Boost::assert
+ Boost::config
+ Boost::type_traits
+)
+
+target_compile_definitions(boost_atomic
+ PUBLIC
+ BOOST_ATOMIC_NO_LIB
+ PRIVATE
+ BOOST_ATOMIC_SOURCE
+)
+
+if(BUILD_SHARED_LIBS)
+ target_compile_definitions(boost_atomic PUBLIC BOOST_ATOMIC_DYN_LINK)
+else()
+ target_compile_definitions(boost_atomic PUBLIC BOOST_ATOMIC_STATIC_LINK)
+endif()
+
+if(BOOST_SUPERPROJECT_VERSION)
+
+ include(BoostInstall)
+ boost_install(TARGETS boost_atomic HEADER_DIRECTORY include/)
+
+endif()