summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/beast/example/websocket/client/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/boost/libs/beast/example/websocket/client/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/beast/example/websocket/client/CMakeLists.txt')
-rw-r--r--src/boost/libs/beast/example/websocket/client/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/boost/libs/beast/example/websocket/client/CMakeLists.txt b/src/boost/libs/beast/example/websocket/client/CMakeLists.txt
new file mode 100644
index 000000000..5d1300e2a
--- /dev/null
+++ b/src/boost/libs/beast/example/websocket/client/CMakeLists.txt
@@ -0,0 +1,19 @@
+#
+# Copyright (c) 2013-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+add_subdirectory (async)
+add_subdirectory (coro)
+add_subdirectory (sync)
+
+if (OPENSSL_FOUND)
+ add_subdirectory (async-ssl)
+ add_subdirectory (async-ssl-system-executor)
+ add_subdirectory (coro-ssl)
+ add_subdirectory (sync-ssl)
+endif()