summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/io/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/boost/libs/io/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/io/CMakeLists.txt')
-rw-r--r--src/boost/libs/io/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/boost/libs/io/CMakeLists.txt b/src/boost/libs/io/CMakeLists.txt
new file mode 100644
index 000000000..c9c1dd040
--- /dev/null
+++ b/src/boost/libs/io/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Copyright 2018 Mike Dev
+#
+# Distributed under the Boost Software License, Version 1.0.
+# (http://www.boost.org/LICENSE_1_0.txt)
+
+cmake_minimum_required(VERSION 3.5)
+
+project(BoostIO LANGUAGES CXX)
+
+add_library(boost_io INTERFACE)
+add_library(Boost::io ALIAS boost_io)
+
+target_include_directories(boost_io INTERFACE include)
+
+target_link_libraries(boost_io INTERFACE Boost::config)