summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/vmd/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/boost/libs/vmd/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/vmd/CMakeLists.txt')
-rw-r--r--src/boost/libs/vmd/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/boost/libs/vmd/CMakeLists.txt b/src/boost/libs/vmd/CMakeLists.txt
new file mode 100644
index 000000000..aeacbc291
--- /dev/null
+++ b/src/boost/libs/vmd/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Copyright 2018 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5)
+project(BoostVmd LANGUAGES)
+
+add_library(boost_vmd INTERFACE)
+add_library(Boost::vmd ALIAS boost_vmd)
+
+target_include_directories(boost_vmd INTERFACE include)
+
+target_link_libraries(boost_vmd
+ INTERFACE
+ Boost::preprocessor
+)