summaryrefslogtreecommitdiffstats
path: root/src/ceph-volume/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/ceph-volume/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/ceph-volume/CMakeLists.txt')
-rw-r--r--src/ceph-volume/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/ceph-volume/CMakeLists.txt b/src/ceph-volume/CMakeLists.txt
new file mode 100644
index 000000000..9166553dc
--- /dev/null
+++ b/src/ceph-volume/CMakeLists.txt
@@ -0,0 +1,29 @@
+
+include(Distutils)
+
+distutils_install_module(ceph_volume
+ INSTALL_SCRIPT ${CMAKE_INSTALL_FULL_SBINDIR})
+
+if(FREEBSD)
+ add_subdirectory(plugin/zfs)
+endif()
+
+# Required for running ceph-volume inventory in a vstart environment
+set(CEPH_VOLUME_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/ceph-volume-virtualenv)
+
+add_custom_command(
+ OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/python
+ COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python3_EXECUTABLE} ${CEPH_VOLUME_VIRTUALENV}
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
+ COMMENT "ceph-volume venv is being created")
+
+add_custom_command(
+ OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume
+ DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/python
+ COMMAND . ${CEPH_VOLUME_VIRTUALENV}/bin/activate && ${CEPH_VOLUME_VIRTUALENV}/bin/python setup.py develop && deactivate
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
+ COMMENT "${CMAKE_SOURCE_DIR}/src/ceph-volume")
+
+add_custom_target(ceph-volume-venv-setup
+ DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume)
+