summaryrefslogtreecommitdiffstats
path: root/src/civetweb/Makefile.osx
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/civetweb/Makefile.osx
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/civetweb/Makefile.osx')
-rw-r--r--src/civetweb/Makefile.osx42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/civetweb/Makefile.osx b/src/civetweb/Makefile.osx
new file mode 100644
index 000000000..44260e84c
--- /dev/null
+++ b/src/civetweb/Makefile.osx
@@ -0,0 +1,42 @@
+#
+# Copyright (c) 2013 No Face Press, LLC
+# License http://opensource.org/licenses/mit-license.php MIT License
+#
+
+# For codesign to work in non-interactive mode, unlock login keychain:
+# security unlock ~/Library/Keychains/login.keychain
+# See e.g. http://lists.apple.com/archives/apple-cdsa/2008/Jan/msg00027.html
+
+# Civetweb features
+WITH_LUA = 1
+
+PACKAGE = Civetweb
+BUILD_DIR = out
+
+CFLAGS += -DUSE_COCOA -DENABLE_CREATE_CONFIG_FILE -mmacosx-version-min=10.4 -ObjC -arch i386 -arch x86_64
+LDFLAGS += -framework Cocoa
+
+DMG_DIR = $(BUILD_DIR)/dmg
+CONTENTS_DIR = $(DMG_DIR)/$(PACKAGE).app/Contents
+RESOURCES_DIR = $(CONTENTS_DIR)/Resources
+OSXBIN_DIR = $(CONTENTS_DIR)/MacOS
+
+CIVETWEB_VERSION = $(shell perl -lne '/define\s+CIVETWEB_VERSION\s+"(\S+)"/ and print $$1' include/civetweb.h)
+ZIPFILENAME = $(PACKAGE)-$(CIVETWEB_VERSION).zip
+
+include Makefile
+
+package: build
+ @rm -rf $(DMG_DIR)
+ install -d -m 755 $(CONTENTS_DIR) $(RESOURCES_DIR) $(OSXBIN_DIR)
+ install -m 644 resources/Info.plist $(CONTENTS_DIR)/
+ install -m 644 resources/civetweb_*.png resources/civetweb.icns $(RESOURCES_DIR)/
+ install -m 644 resources/itworks.html $(OSXBIN_DIR)/index.html
+ install -m 644 resources/civetweb_64x64.png $(OSXBIN_DIR)/
+ install -m 755 $(CPROG) $(OSXBIN_DIR)/$(PACKAGE)
+ install -m 644 docs/Installing.md $(DMG_DIR)/Installing.txt
+ install -m 644 LICENSE.md $(DMG_DIR)/License.txt
+ rm -rf $(ZIPFILENAME)
+ cd $(DMG_DIR) && zip -r ../../$(ZIPFILENAME) .
+
+.PHONY: package