summaryrefslogtreecommitdiffstats
path: root/src/civetweb/distribution
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/civetweb/distribution
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/civetweb/distribution')
-rw-r--r--src/civetweb/distribution/arch/PKGBUILD.git.example42
-rw-r--r--src/civetweb/distribution/arch/civetweb.service9
2 files changed, 51 insertions, 0 deletions
diff --git a/src/civetweb/distribution/arch/PKGBUILD.git.example b/src/civetweb/distribution/arch/PKGBUILD.git.example
new file mode 100644
index 000000000..7102bcb34
--- /dev/null
+++ b/src/civetweb/distribution/arch/PKGBUILD.git.example
@@ -0,0 +1,42 @@
+# An example PKGBUILD script for Civetweb upstream, git version
+# Rename to PKGBUILD to build via makepkg
+_pkgname=civetweb
+pkgname=$_pkgname-git
+pkgver=v1.4.24.g73c40b6
+pkgrel=1
+pkgdesc="Small and quick-to-use web server; https/php/cgi support; MIT license - git development version"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/p/civetweb/"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git sed')
+optdepends=('php-cgi: for php support')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+backup=("etc/$_pkgname/$_pkgname.conf")
+source=("$_pkgname::git+https://github.com/civetweb/civetweb.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make build WITH_IPV6=1
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make install PREFIX="$pkgdir/usr" SYSCONFDIR="$pkgdir/etc/local/$_pkgname"
+
+ install -Dm644 "$srcdir/$_pkgname/distribution/arch/$_pkgname.service" "$pkgdir/usr/lib/systemd/system/$_pkgname.service"
+
+ sed -i "s/^document_root [^\n]*/document_root \/srv\/http/g" "$pkgdir/etc/local/$_pkgname/$_pkgname.conf"
+ sed -i "s/^# access_log_file/access_log_file \/var\/log\/$_pkgname\/access.log/g" "$pkgdir/etc/local/$_pkgname/$_pkgname.conf"
+ sed -i "s/^# error_log_file/access_log_file \/var\/log\/$_pkgname\/error.log/g" "$pkgdir/etc/local/$_pkgname/$_pkgname.conf"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/src/civetweb/distribution/arch/civetweb.service b/src/civetweb/distribution/arch/civetweb.service
new file mode 100644
index 000000000..5327b6caa
--- /dev/null
+++ b/src/civetweb/distribution/arch/civetweb.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Civetweb httpd
+After=syslog.target network.target remote-fs.target nss-lookup.target
+
+[Service]
+ExecStart=/usr/local/bin/civetweb /usr/local/etc/civetweb/civetweb.conf
+
+[Install]
+WantedBy=multi-user.target