summaryrefslogtreecommitdiffstats
path: root/src/civetweb/resources/jni/Android.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/civetweb/resources/jni/Android.mk
parentInitial commit. (diff)
downloadceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.tar.xz
ceph-19fcec84d8d7d21e796c7624e521b60d28ee21ed.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/civetweb/resources/jni/Android.mk')
-rw-r--r--src/civetweb/resources/jni/Android.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/civetweb/resources/jni/Android.mk b/src/civetweb/resources/jni/Android.mk
new file mode 100644
index 000000000..f24981a60
--- /dev/null
+++ b/src/civetweb/resources/jni/Android.mk
@@ -0,0 +1,6 @@
+LOCAL_PATH := $(call my-dir)/../..
+include $(CLEAR_VARS)
+LOCAL_CFLAGS := -std=c99 -O2 -W -Wall -pthread -pipe $(COPT)
+LOCAL_MODULE := civetweb
+LOCAL_SRC_FILES := src\main.c src\civetweb.c
+include $(BUILD_EXECUTABLE)