summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/lib/rb/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/jaegertracing/thrift/lib/rb/Makefile.am
parentInitial commit. (diff)
downloadceph-6d07fdb6bb33b1af39833b850bb6cf8af79fe293.tar.xz
ceph-6d07fdb6bb33b1af39833b850bb6cf8af79fe293.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/jaegertracing/thrift/lib/rb/Makefile.am')
-rwxr-xr-xsrc/jaegertracing/thrift/lib/rb/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/lib/rb/Makefile.am b/src/jaegertracing/thrift/lib/rb/Makefile.am
new file mode 100755
index 000000000..1841065f5
--- /dev/null
+++ b/src/jaegertracing/thrift/lib/rb/Makefile.am
@@ -0,0 +1,55 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+DESTDIR ?= /
+
+if HAVE_BUNDLER
+
+all-local:
+ $(BUNDLER) install
+ $(BUNDLER) exec rake build_ext
+
+install-exec-hook:
+ $(BUNDLER) exec rake install
+
+clean-local:
+ $(BUNDLER) install
+ $(BUNDLER) exec rake clean
+ $(RM) -r spec/gen-rb/
+
+check-local: all
+ $(BUNDLER) install
+ $(BUNDLER) exec rake
+
+endif
+
+dist-hook:
+ $(RM) -r $(distdir)/spec/gen-rb/
+
+EXTRA_DIST = \
+ coding_standards.md \
+ Rakefile \
+ Gemfile \
+ thrift.gemspec \
+ lib \
+ ext \
+ benchmark \
+ script \
+ spec \
+ README.md