summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/thrift/test/erl/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/jaegertracing/thrift/test/erl/Makefile.am
parentInitial commit. (diff)
downloadceph-6d07fdb6bb33b1af39833b850bb6cf8af79fe293.tar.xz
ceph-6d07fdb6bb33b1af39833b850bb6cf8af79fe293.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/jaegertracing/thrift/test/erl/Makefile.am')
-rw-r--r--src/jaegertracing/thrift/test/erl/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/jaegertracing/thrift/test/erl/Makefile.am b/src/jaegertracing/thrift/test/erl/Makefile.am
new file mode 100644
index 000000000..81913eefd
--- /dev/null
+++ b/src/jaegertracing/thrift/test/erl/Makefile.am
@@ -0,0 +1,51 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+THRIFT_FILES = $(wildcard ../*.thrift)
+
+if ERLANG_OTP16
+ERL_FLAG = erl:otp16
+else
+ERL_FLAG = erl
+endif
+# make sure ThriftTest.thrift is generated last to prevent conflicts with other *.thrift files
+.generated: $(THRIFT_FILES)
+ for f in $(THRIFT_FILES) ; do \
+ $(THRIFT) --gen $(ERL_FLAG) -o src $$f ; \
+ done ; \
+ $(THRIFT) --gen $(ERL_FLAG) -o src ../ThriftTest.thrift
+ touch .generated
+
+precross: .generated
+ $(REBAR) compile
+
+maintainer-clean-local:
+ $(RM) -r ebin/
+
+clean:
+ $(REBAR) clean
+ $(RM) .generated
+ $(RM) -r .rebar/
+ $(RM) -r src/gen-erl/
+
+dist-hook:
+ $(RM) $(distdir)/.generated
+ $(RM) -r $(distdir)/.rebar/
+ $(RM) -r $(distdir)/ebin/
+ $(RM) -r $(distdir)/src/gen-erl/