summaryrefslogtreecommitdiffstats
path: root/src/ocf/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/ocf/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/ocf/CMakeLists.txt')
-rw-r--r--src/ocf/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/ocf/CMakeLists.txt b/src/ocf/CMakeLists.txt
new file mode 100644
index 000000000..9a87d02f1
--- /dev/null
+++ b/src/ocf/CMakeLists.txt
@@ -0,0 +1,10 @@
+# The root of the OCF resource agent hierarchy
+# Per the OCF standard, it's always "lib",
+# not "lib64" (even on 64-bit platforms).
+set(ocf_dir ${CMAKE_INSTALL_PREFIX}/lib/ocf)
+
+# The ceph provider directory
+set(ra_dir ${ocf_dir}/resource.d/${PROJECT_NAME})
+
+configure_file(rbd.in rbd @ONLY)
+install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/rbd DESTINATION ${ra_dir})