summaryrefslogtreecommitdiffstats
path: root/src/perfglue/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:45:59 +0000
commit19fcec84d8d7d21e796c7624e521b60d28ee21ed (patch)
tree42d26aa27d1e3f7c0b8bd3fd14e7d7082f5008dc /src/perfglue/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/16.2.11+ds.tar.xz
ceph-upstream/16.2.11+ds.zip
Adding upstream version 16.2.11+ds.upstream/16.2.11+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/perfglue/CMakeLists.txt')
-rw-r--r--src/perfglue/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/perfglue/CMakeLists.txt b/src/perfglue/CMakeLists.txt
new file mode 100644
index 000000000..b2cb608da
--- /dev/null
+++ b/src/perfglue/CMakeLists.txt
@@ -0,0 +1,22 @@
+if(ALLOCATOR STREQUAL "tcmalloc" AND NOT WITH_SEASTAR)
+ add_library(heap_profiler STATIC
+ heap_profiler.cc)
+ target_link_libraries(heap_profiler
+ gperftools::tcmalloc)
+else()
+ add_library(heap_profiler STATIC
+ disabled_heap_profiler.cc)
+endif()
+
+option(WITH_PROFILER "build extra profiler binaries" OFF)
+
+if(WITH_PROFILER)
+ find_package(gperftools REQUIRED profiler)
+ add_library(cpu_profiler STATIC
+ cpu_profiler.cc)
+ target_link_libraries(cpu_profiler
+ gperftools::profiler)
+else()
+ add_library(cpu_profiler STATIC
+ disabled_stubs.cc)
+endif()